1. karusel38

    karusel38 New Member

    Joined:
    16 Oct 2018
    Messages:
    20
    Likes Received:
    2
    Reputations:
    0
    Всем привет, не могу установить! Помогите пожалуйста)
     
  2. saimonyz

    saimonyz Member

    Joined:
    23 Jun 2012
    Messages:
    162
    Likes Received:
    41
    Reputations:
    2
  3. karusel38

    karusel38 New Member

    Joined:
    16 Oct 2018
    Messages:
    20
    Likes Received:
    2
    Reputations:
    0
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    libnl-3-dev : Зависит: libnl-3-200 (= 3.2.27-2) но 3.4.0-1 будет установлен
    libnl-genl-3-dev : Зависит: libnl-genl-3-200 (= 3.2.27-2) но 3.4.0-1 будет установлен
    libpcap-dev : Зависит: libpcap0.8-dev но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    [email protected]:~# cd mdk4
    [email protected]:~/mdk4# make
    make -C src clean
    make[1]: вход в каталог «/root/mdk4/src»
    /bin/sh: 1: pkg-config: not found
    /bin/sh: 1: pkg-config: not found
    /bin/sh: 1: pkg-config: not found
    /bin/sh: 1: pkg-config: not found
    /bin/sh: 1: pkg-config: not found
    ../common.mak:100: *** Cannot find development files for any supported version of libnl. install either libnl1 or libnl3.. Останов.
    make[1]: выход из каталога «/root/mdk4/src»
    make: *** [Makefile:20: clean] Ошибка 2
     
  4. daemon_mors

    daemon_mors Elder - Старейшина

    Joined:
    12 Feb 2014
    Messages:
    821
    Likes Received:
    7,398
    Reputations:
    12
    Зачем было ставить систему на русском, если все равно не понимаешь что тут написано? На английском хоть было бы проще гуглить ошибки...
     
    Toroid, binarymaster and Payer like this.
  5. Altair203

    Altair203 New Member

    Joined:
    11 Nov 2018
    Messages:
    8
    Likes Received:
    3
    Reputations:
    0
    Почти те же ошибки у меня. Всё-таки как установить эту MDK4?
    Нашёл в чём причина: нужно в /etc/apt/sources.list добавить строчку
    "deb http://http.kali.org/kali kali-rolling main non-free contrib"
    и затем в терминале обновить sudo apt-get update
     
    #5 Altair203, 3 Jan 2020
    Last edited: 4 Jan 2020
    Adagumer likes this.
Loading...