Авторские статьи Metasploit Framework для ламеров

Обсуждение в разделе «Статьи», начал(-а) -=lebed=-, 11.07.2006.

?
  1. Да, пользуюсь и доволен.

    50,7%
  2. Нет, он меня не устраивает, не нужен и т. п.

    14,9%
  3. А что это?

    34,4%
  1. Amikan

    Amikan New Member

    Регистрация:
    20.01.2016
    Сообщения:
    11
    Одобрения:
    0
    Репутация:
    0
    ВОзможно строка для переполнения не той длины????:confused:
     
  2. some-one

    some-one New Member

    Регистрация:
    6.10.2015
    Сообщения:
    25
    Одобрения:
    2
    Репутация:
    0
    День добрый. Скажите пожалуйста. Установил mestaploit3 через mac ports 2.3.4. OS X 10.10.5 .
    Ввожу от рута в терминале msfconsole. Scapy установлен.

    Результат:


    sh-3.2# msfconsole

    /opt/local/libexec/metasploit3/lib/rex/socket.rb:30: warning: already initialized constant Socket::AF_INET6

    DL is deprecated, please use Fiddle

    /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': /opt/local/libexec/metasploit3/lib/rex/ui/text/input/socket.rb:60: invalid multibyte escape: /\xff\xf4\xff\xfd\x06/ (SyntaxError)

    invalid multibyte escape: /\xff\xed\xff\xfd\x06/

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /opt/local/libexec/metasploit3/lib/rex/ui/text/input.rb:18:in `<class:Input>'

    from /opt/local/libexec/metasploit3/lib/rex/ui/text/input.rb:14:in `<module:Text>'

    from /opt/local/libexec/metasploit3/lib/rex/ui/text/input.rb:5:in `<module:Ui>'

    from /opt/local/libexec/metasploit3/lib/rex/ui/text/input.rb:4:in `<module:Rex>'

    from /opt/local/libexec/metasploit3/lib/rex/ui/text/input.rb:3:in `<top (required)>'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /opt/local/libexec/metasploit3/lib/rex/ui.rb:11:in `<top (required)>'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /opt/local/libexec/metasploit3/lib/msf/ui.rb:6:in `<top (required)>'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

    from /opt/local/sbin/msfconsole:11:in `<main>'


    Вопрос: в чем проблема? Как исправить?
     
  3. Scanner17

    Scanner17 New Member

    Регистрация:
    31.12.2017
    Сообщения:
    17
    Одобрения:
    0
    Репутация:
    0
    Здравствуйте! Извините, если повторяю вопросы, которые уже обсуждались. В наличии Live USB Kali Linux 2017.3 с Metasploit на борту. С помощью этой программы хочу попробовать достать логин и пароль для роутера, который подключен к моему ПК по Ethernet (LAN). Как обновить программу в Kali Linux? Как в ней просканировать роутер? Есть ли автоматизация для поиска эксплойтов? Заранее благодарю за помощь!
     
    #483 Scanner17, 11.01.2018
    В последний раз редактировалось: 11.01.2018
  4. artkar

    artkar Active Member

    Регистрация:
    14.11.2016
    Сообщения:
    299
    Одобрения:
    254
    Репутация:
    2
    канешн есть! Там опредиит что за сервисы запущены и сплоеты предложит, по крайне мере раньше так було.
    update как то так вроде команда звучит. А че вы все Кали юзаете не проще ли метас под винду поставить?
     
    Это одобряет Scanner17.
  5. Scanner17

    Scanner17 New Member

    Регистрация:
    31.12.2017
    Сообщения:
    17
    Одобрения:
    0
    Репутация:
    0
    Спасибо! Буду разбираться.
    Благодарю! Я записал Kali Linux на флешку и использую вариант Live USB просто для разовой проверки возможности решить свою проблему с помощью Metasploit. В Windows его не стал устанавливать по той причине, что не планирую его использовать часто и постоянно (по крайней мере в ближайшее время).
     
Загрузка...
Similar Threads - Metasploit Framework ламеров
  1. Seymour
    Ответы:
    16
    Просмотры:
    20 215
  2. -=lebed=-
    Ответы:
    54
    Просмотры:
    30 671
  3. n0ne
    Ответы:
    13
    Просмотры:
    25 335
  4. -=lebed=-
    Ответы:
    12
    Просмотры:
    30 641